Beranda > Networking > Konfigurasi VPN Server Site-to-Site IPSec dengan Sistem Vyatta

Konfigurasi VPN Server Site-to-Site IPSec dengan Sistem Vyatta

Sebelum kita mulai untuk konfigurasi VPN menggunakan Vyatta, saya akan menjelaskan terlebih dahulu agar konfigurasi di bawah yang akan saya tulis mudah di mengerti,

Untuk menjelaskannya saya akan mengambarkan Study Kasus sederhana dari implementasi VPN,

Misalkan ada sebuah Perusahaan bernama PT.XYZ yang mempunyai Kantor Cabang di Bogor, Bandung, Jakarta, Depok. Dan permasalahannya Bagaimana jika Kantor XYZ Cabang Bogor, Bandung, dan Depok dalam pekerjaannya membutuhkan ketersediaan server utama yang berada di Jakarta, dan Untuk mempermudah dan keamanan pekerjaan tersebut di butuhkan pembentukan suatu jaringan Lokal,
Nah Jaringan Lokal? Apa bisa Gedung yang berjauhan di sebut Local Area Network,,
Jawabannya BISA,,itulah salah satu fungsi dari penerapan VPN (Virtual Private Network).

Sekarang pertanyaannya Bagaimana bisa Jaringan yang berjauhan bisa terhubung dan kita buat seperti Local Area Network??

Bisa, Tetap kita menggunakan WAN (Untuk Menghubungkannnya) tetapi kita buat Private (VPN), Jadi bisa juga kita katakan menciptakan terowongan pribadi di Internet dengan Enkripsi,

Oleh karena itu Teknologi VPN banyak juga yang menyebutnya Tunneling.

Untuk Lebih Lengkapnya Amati Gambar Berikut ini :

Untuk Tutotial ini saya asumsikan 2 cabang dahulu untuk lebih sederhana, Misalkan VYATTA VPN1 (BOGOR) dan VYATTA VPN2 (JAKARTA) ditambah 1 simulasi INTERNET (Juga menggunakan Vyatta)

Spesifikasinya :

R (Simulasi Internet)

IP GW untuk R1       : 223.134.172.1/27 (eth1)

IP GW untuk R2      : 208.122.230.1/24 (eth2)

R1

IP Outside : 223.134.172.2/27 (eth1)

IP Lokal      : 192.168.1.1/24 (eth2)

R2

IP Outside : 208.122.230.2/24 (eth1)

IP Lokal      : 10.100.1.1/24 (eth2)

Oke Mulai Kita Konfigurasi dengan Asumsi Vyatta sudah terinstall (Saya pribadi memakai Vyatta Core 6.1):

R1 (Router NAT XYZ Jakarta)

vyatta@f0xb4t #set interfaces ethernet eth2 address 192.168.1.1/24
vyatta@f0xb4t#set interfaces ethernet eth1 address 223.134.172.2/27
vyatta@f0xb4t#set protocols ospf area 1 network 223.134.172.0/27
vyatta@f0xb4t#set protocols ospf passive-interface eth1
vyatta@f0xb4t#set protocols static route 0.0.0.0/0 next-hop 223.134.172.1
vyatta@f0xb4t#set vpn ipsec ipsec-interfaces interface eth2
vyatta@f0xb4t#show vpn ipsec ipsec-interfaces
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R1 proposal 1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R1 proposal 1 encryption aes256
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R1 proposal 1 hash sha1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1 R1 proposal 2 encryption aes128
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1 R1 proposal 2 hash sha1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R1 lifetime 3600
vyatta@f0xb4t#show -all vpn ipsec ike-group IKE-1R1
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 proposal 1
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 proposal 1 encryption aes256
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 proposal 1 hash sha1
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 proposal 2 encryption 3des
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 proposal 2 hash md5
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R1 lifetime 1800
vyatta@f0xb4t#show -all vpn ipsec esp-group ESP-1R1
vyatta@f0xb4t#set vpn ipsec site-to-site peer 208.122.230.2 authentication mode
pre-shared-secret
vyatta@f0xb4t#edit vpn ipsec site-to-site peer208.122.230.2
vyatta@f0xb4t#set authentication pre-shared-secret test_key_1
vyatta@f0xb4t#set ike-group IKE-1R1
vyatta@f0xb4t#set local-ip 222.124.194.2
vyatta@f0xb4t#set tunnel 1 local-subnet 192.168.1.0/24
vyatta@f0xb4t#set tunnel 1 remote-subnet 10.100.1.0/24
vyatta@f0xb4t#set tunnel 1 esp-group ESP-1R1
vyatta@f0xb4t#top
vyatta@f0xb4t#commit
vyatta@f0xb4t#show -all vpn ipsec site-to-site peer208.122.230.2
vyatta@f0xb4t#exit
vyatta@f0xb4t# vpn rsa-key generate

vyatta@f0xb4t#commit
vyatta@f0xb4t#save

REMOTE ACCESS
vyatta@f0xb4t#set vpn pptp remote-access client-ip-pool start 192.168.1.50
vyatta@f0xb4t#set vpn pptp remote-access client-ip-pool stop 192.168.1.60
vyatta@f0xb4t#set vpn pptp remote-access authentication mode local
vyatta@f0xb4t#set vpn pptp remote-access authentication local-users username verrysoon
password 12345

vyatta@f0xb4t#set service nat rule 10 type source
vyatta@f0xb4t#set service nat rule 10 source address 192.168.1.0/24
vyatta@f0xb4t#set service nat rule 10 outbound-interface eth1
vyatta@f0xb4t#set service nat rule 10 outside-address address 208.122.230.2/24

ROUTER (Simulasi internet)

vyatta@f0xb4t!#set interfaces ethernet eth1 address 223.134.172.1/27
vyatta@f0xb4t!#set interfaces ethernet eth2 address 208.122.230.1/24
vyatta@f0xb4t!#set protocols ospf area 1 network 223.134.172.0/27
vyatta@f0xb4t!#set protocols ospf area 1 network 208.122.230.0/24

R2 (Router NAT XYZ Bogor)

vyatta@f0xb4t##configure
vyatta@f0xb4t##set system host-name R2
vyatta@f0xb4t##set interfaces ethernet eth1 address 208.122.230.2/24 (eth1)
vyatta@f0xb4t#set interfaces ethernet eth2 address 10.100.1.1/24 (eth2)
vyatta@f0xb4t#set protocols ospf area 0 network 208.122.230.2/24
vyatta@f0xb4t#set protocols ospf passive-interface eth2
vyatta@f0xb4t#set protocols static route 0.0.0.0/0 next-hop 208.122.230.1
vyatta@f0xb4t#set vpn ipsec ipsec-interfaces interface eth1
vyatta@f0xb4t#show vpn ipsec ipsec-interfaces
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 proposal 1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 proposal 1 encryption aes256
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 proposal 1 hash sha1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 proposal 2 encryption aes128
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 proposal 2 hash sha1
vyatta@f0xb4t#set vpn ipsec ike-group IKE-1R3 lifetime 3600
vyatta@f0xb4t#show -all vpn ipsec ike-group IKE-1R3
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 proposal 1
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 proposal 1 encryption aes256
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 proposal 1 hash sha1
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 proposal 2 encryption 3des
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 proposal 2 hash md5
vyatta@f0xb4t#set vpn ipsec esp-group ESP-1R3 lifetime 1800
vyatta@f0xb4t#show -all vpn ipsec esp-group ESP-1R3
vyatta@f0xb4t#set vpn ipsec site-to-site peer 223.134.172.2 authentication mode pre-
shared-secret

vyatta@f0xb4t#edit vpn ipsec site-to-site peer 223.134.172.2
vyatta@f0xb4t#set authentication pre-shared-secret test_key_1
vyatta@f0xb4t#set ike-group IKE-1R3
vyatta@f0xb4t#set local-ip 208.122.230.2
vyatta@f0xb4t#set tunnel 1 local-subnet 10.100.1.1/24
vyatta@f0xb4t#set tunnel 1 remote-subnet 192.168.1.0/24
vyatta@f0xb4t#set tunnel 1 esp-group ESP-1R3
vyatta@f0xb4t#top
vyatta@f0xb4t#commit
vyatta@f0xb4t#show -all vpn ipsec site-to-site peer 223.134.172.2
vyatta@f0xb4t#exit

vyatta@f0xb4t#commit
vyatta@f0xb4t#save

Untuk Mengakses VPN Server :

Client dengan OS Linux Ubuntu :

1. Klik Pada Icon Network > VPN Connection > Configure VPN

2. Pada TAB VPN pilih Add > PPTP > Create

3.Masukan Gateway di Field gateway 192.168.1.1 (Yang Telah di buat tadi)

4. Masukan Username : Verrysoon dan Password : 12345 > Apply (Ceklis Connect Automaticaly)

5. Setelah di Apply tunggu auntentikasi selesai

6. Cek IP Address di terminal dengan perintah ifconfig -all

7. Lakukan Perintah ping ke salah satu client yang ada pada Local Area Network Tersebut. Jika Reply berarti Konfigurasi VPN Server tersebut telah berhasil

Sumber : http://vyatta.org & http://candra.unsri.ac.id

Regards,

Verrysoon

http://tar-xzvf.web.id

  1. Belum ada komentar.
  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s